Page 1 of 1

"No underlying compiler was specified..."

PostPosted: Mon Nov 10, 2014 11:17 am
by naslundx
I'm trying to build the Trilinos package (a lot of linear algebra solvers etc.) on the Parallella. It uses CMake, but half-way through it fails when identifying and testing the Fortran compiler. I get the following:

Code: Select all
-- The Fortran compiler identification is unknown
-- Check for working Fortran compiler: /usr/local/bin/mpif90
-- Check for working Fortran compiler: /usr/local/bin/mpif90  -- broken
CMake Error at /usr/share/cmake-2.8/Modules/CMakeTestFortranCompiler.cmake:54 (message):
  The Fortran compiler "/usr/local/bin/mpif90" is not able to compile a
  simple test program.

The gfortran compiler is installed, and I can successfully compile C and C++ programs with MPI. However, if I run the mpif90 command in the terminal, I get:

"No underlying compiler was specified in the wrapper compiler data file (e.g., mpicc-wrapper-data.txt)"

I've tried googling without any luck. Is there some missing Fortran/OpenMPI support on the Parallella? Any idea what to do?

EDIT: After editing /usr/local/share/openmpi/f90-wrapper-data.txt and adding gfortran by compiler, the error in CMake is still the same, but at least it says "The Fortran compiler identification is GNU".

Re: "No underlying compiler was specified..."

PostPosted: Wed Dec 03, 2014 1:24 pm
by aolofsson
Were you able to get this resolved?
Did you try setting: Trilinos_ENABLE_Fortran option to OFF.