Preventing Screen Sleep in Graphical Session

Forum about Parallella boot process, linux kernel, distros, SD-cards, etc.

Preventing Screen Sleep in Graphical Session

Postby dcd4408 » Tue Jun 07, 2016 3:23 pm

What is the proper way to prevent (or change the time delay of) the screen from blacking out during a graphical session under this operating system?

Thanks!
dcd4408
 
Posts: 7
Joined: Wed Jul 29, 2015 3:19 pm

Re: Preventing Screen Sleep in Graphical Session

Postby sebraa » Wed Jun 08, 2016 5:33 pm

In X11, you can run "xset -dpms" to turn off screen blanking.
However, screen savers (e.g. xscreensaver) will override this setting, so you need to disable them first.
sebraa
 
Posts: 495
Joined: Mon Jul 21, 2014 7:54 pm

Re: Preventing Screen Sleep in Graphical Session

Postby dcd4408 » Thu Jun 09, 2016 4:18 pm

I had tried something similar before but not exactly.

The command the ultimately solves both problems (screen blanking and screen saver) is

Code: Select all
xset s off -dpms
dcd4408
 
Posts: 7
Joined: Wed Jul 29, 2015 3:19 pm


Return to Linux/U-Boot

Who is online

Users browsing this forum: No registered users and 2 guests

cron