openCL SDK

Moderator: dar

openCL SDK

Postby Nader_Jendoubi » Wed Apr 01, 2015 1:33 pm

Hi

I have a image processing project and a code to develop with openCL
i wanna ask if the parallella Ubuntu image include the appropriate SDK (COPTHR) for developping with openCL or should i build it by myself(if this is the case, please give me the build sequence)

How can i build the host and device(kernel) parts of the code??



Thanks
Nader_Jendoubi
 
Posts: 41
Joined: Wed Feb 18, 2015 6:53 pm

Re: openCL SDK

Postby nickoppen » Sat Apr 04, 2015 5:40 am

Hi,

The parallella image does include the Brown Deer OpenCL compiler. If you are just starting out, I suggest using the image that is downloadable from the parallella.org site. I've just started using it and the compiler seems to be working well.

If you want to build it from scratch have a look at: http://www.browndeertechnology.com/docs/Parallella_quick_start_guide.pdf and get the source using the command: git clone https://github.com/browndeer/coprthr.git

nick
Sharing is what makes the internet Great!
User avatar
nickoppen
 
Posts: 266
Joined: Mon Dec 17, 2012 3:21 am
Location: Sydney NSW, Australia

Re: openCL SDK

Postby Nader_Jendoubi » Sun Apr 05, 2015 3:06 pm

Hi

Thanks for the clarification but can you please indicate to me the directory of the the Brown Deer OpenCL compiler in the Linux Ubuntu Linaro 14.04 for parallella (like /opt/adapteva for eSDK)


Regards

Nader
Nader_Jendoubi
 
Posts: 41
Joined: Wed Feb 18, 2015 6:53 pm

Re: openCL SDK

Postby nickoppen » Mon Apr 06, 2015 10:27 am

/usr/local/browndeer and then under that there is the usual /lib /include etc.
Sharing is what makes the internet Great!
User avatar
nickoppen
 
Posts: 266
Joined: Mon Dec 17, 2012 3:21 am
Location: Sydney NSW, Australia

Re: openCL SDK

Postby fbt » Fri Jan 15, 2016 12:17 pm

Hi @nickoppen, i followed your "openCL on the parallella using Eclipse" tutorial, but when i try to run the mandelbrot from Eclipse, i obtain some errors related to supervisor requirements ... but when i run the executable build file from a terminal (after "sudo bash"), it runs OK. could ypu please help me to solve this issue and reach executing the project from Eclipse?. thanks
fbt
 
Posts: 5
Joined: Thu Dec 17, 2015 11:55 am


Return to OpenCL

Who is online

Users browsing this forum: No registered users and 1 guest